Using Workstation to deploy a Virtual Service that doesn't start
search cancel

Using Workstation to deploy a Virtual Service that doesn't start

book

Article ID: 203590

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

Have a client environment, when we deploy a VS using workstation it does not start (deploy correctly )>
We get the error:

 Exception: 
============================================================================
| Message:     java.lang.NullPointerException
----------------------------------------------------------------------------
| Trapped Exception: null
| Trapped Message:   java.lang.NullPointerException
----------------------------------------------------------------------------
STACK TRACE
java.lang.NullPointerException
============================================================================

• The problem occurs only on this account_balance, by repeating the same deployment operations the other VS deploys correctly.
• Taking the MAR file  of Vs account_balance from the TEST environment where it is correctly in the Running state, the problem occurs in the production environment
• I noticed that it fails to write to folders related to the deployment of the VS example: E: \ CA \ DevTest \ lisatmp_10.5.0 \ lads

 

Environment

All supported DevTest releases.

Cause

There was a port conflict outside of the Devtest application with the new VSE that was trying to be deployed.

Resolution

 

The problem was a port conflict on port 8010 for the virtual service and something outside of DevTest on the OS.

Troubleshooting steps:
1) Tried to deploy the virtual service and received the same error.
2) Removed the VSE from the portal
3) Cleaned up the VSE information from the vseDeploy directory
4) Did the deployment again and failed.
5) Removed the VSE from the Portal
6) Then went into the Workstation and changed the port from 8010 to 8020 and saved it
7) Re-deployed the service and it worked.

You can run the windows command netstat -ano to find the process PID that is using port 8010.
You can then use the task manager to find the PID to determine what the application is.

Should NetStat -ano not show the port in question reboot the entire server and test again



Additional Information

From the VSE log

============================================================================
| Exception: 
============================================================================
| Message:     java.lang.NullPointerException
----------------------------------------------------------------------------
| Trapped Exception: null
| Trapped Message:   java.lang.NullPointerException
----------------------------------------------------------------------------
STACK TRACE
java.lang.NullPointerException
    at com.itko.lisa.vse.http.TextHTTPServer.serverClosed(TextHTTPServer.java:265)
    at com.itko.lisa.vse.sio.PortServer.close(PortServer.java:196)
    at com.itko.lisa.vse.sio.NIOPortServer.<init>(NIOPortServer.java:78)
    at com.itko.lisa.vse.sio.DefaultPortServerFactory.createPortServer(DefaultPortServerFactory.java:48)
    at com.itko.lisa.vse.sio.PortServer.createPortServer(PortServer.java:81)
    at com.itko.lisa.vse.http.TextHTTPServer.<init>(TextHTTPServer.java:118)
    at com.itko.lisa.vse.http.TextHTTPServer.getServer(TextHTTPServer.java:84)
    at com.itko.lisa.vse.stateful.protocol.http.HttpListenStep.execute(HttpListenStep.java:462)
    at com.itko.lisa.test.TestNode.executeNode(TestNode.java:995)
    at com.itko.lisa.test.TestCase.execute(TestCase.java:1297)
    at com.itko.lisa.test.TestCase.execute(TestCase.java:1198)
    at com.itko.lisa.test.TestCase.executeNextNode(TestCase.java:1183)
    at com.itko.lisa.test.TestCase.executeTest(TestCase.java:1124)
    at com.itko.lisa.coordinator.Instance.run(Instance.java:208)
============================================================================