Where is the SMTP email setting for scheduled reports in Cabi for UIM 20.x
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Where is the SMTP email setting for scheduled reports in Cabi for UIM 20.x

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Article ID: 203516

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Where do I locate and configure the SMTP Email setting for emailing scheduled reports in Cabi for UIM 20.x?

 

Environment

Release : 20.x

Cause

As reports in UIM 20.x are managed by CABI, the SMTP settings need to be configured on the CABI server.

Resolution

* Stop the robot where CABI is running and restart it after the changes are made * 

1- Go to \Nimsoft\probes\service\wasp\webapps\cabijs\WEB-INF folder  
2- Create a backup of js.quartz.properties file 
3- Edit js.quartz.properties file as shown below, edit the bold values to match with your setup: 

report.scheduler.web.deployment.uri=http(s)://<cabi-ip-or-fqdn>:<port>/cabijs

report.scheduler.mail.sender.host=smtp.example.com (The FQDN of the mail server) 

report.scheduler.mail.sender.username=smtp_user_name_(The name of the mail server user that JasperReports Server can use) 

report.scheduler.mail.sender.password=smtp_password_ (The password of the mail server user) 

report.scheduler.mail.sender.from=[email protected] (The address that appears in the From field on email notifications) 

report.scheduler.mail.sender.protocol=smtp (The protocol that the mail server uses. JasperReports Server only supports SMTP.)

NOTE: If your mail server does not require a user name or password, leave the values empty - for example: 

report.scheduler.mail.sender.username=
report.scheduler.mail.sender.password=

WARNING: If you add # at the start of the lines above it will cause the file to corrupt and CABI will be unable to start. 

Additional Information

Configure the SMTP Email Setting for Emailing Scheduled Reports