OC Inventory shows the robot with the old origin
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OC Inventory shows the robot with the old origin

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Article ID: 203511

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We changed the origin on a robot followed by a clean niscache, _reset_device_id_and_restart and a device delete from the OC Inventory but the robot still populates with the old origin.

Why is the robot populated with old origin?

Environment

Any UIM version

Cause

This issue is seen when a source in the UIM Infrastructure, robot/device/probe still has the robot with the old origin..

Resolution

Review the CM_DEVICE , CM_COMPUTER_SYSTEM_ATTR and CM_DEVICE_ATTRIBUTE to identify source that is populating the robot instances

1. Query to display all entries for a given robot in the cm_device table
select * from CM_DEVICE where dev_name = '%myrobot%'

2. Query to identify sources that are publishing a given device. 
Run query below against all distinct dev_src_ids returned in Step 1 and note the robot name.
select * from CM_DEVICE where dev_id = '%DeviceID%'

3. Query to display attributes for a given dev_id including origin; dev_attr_key.
Run query below against all device_ids in Step 2 and identify the robot that shows the old origin

select * from CM_DEVICE_ATTRIBUTE where dev_id = '%DeviceID%'

4. Launch IM and select the robot that showed the old origin in Step 3

5. Select the controller probe and press Ctrl-P. The probe utility window will pop up.

6. Click the Options Icon - (second icon from the right) Select the 'Expert Mode' checkbox, Click Ok.

7. Now, in the "Probe Commandset" select _nis_cache_clean and click the Green Arrow to send the command request.

8. Delete the robot from the OC Inventory list, Uncheck options "Delete Measurement and "Prevent rediscovery"

Allow enough time for the robot to be added to the OC Inventory and check the origin