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Excess Trace Log Messages on Policy Servers

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Article ID: 203427

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) SITEMINDER

Issue/Introduction

We are seeing a huge amount of smtrace logs generated every min on one of our policy servers. I am trying to understand the root cause of it.

In one of the logs, I saw this snippet. Its been occurring multiple times.

[11/10/2020][13:44:08.149][13:44:08][44060][16216][XPSObject.cpp:4156][CXPSObjectImpl::getXPSValue][][][][][][][][][][][][][][][][][][][][][13554092-8472-4b23-be29-69d9bd22dfbb: Enter CXPSObjectImpl::getXPSValue]

[11/10/2020][13:44:08.149][13:44:08][44060][16216][][CXPSObjectImpl::getXPSValue][][][][][][][][][][][][][][][][][][][][][Exit CXPSObjectImpl::getXPSValue]

[11/10/2020][13:44:08.149][13:44:08][44060][16216][][IXPSObjectV1::getAttributeA][][][][][][][][][][][][][][][][][][][][][Exit IXPSObjectV1::getAttributeA]

[11/10/2020][13:44:08.149][13:44:08][44060][16216][XPSObject.cpp:2760][IXPSObjectV1::getValueCount][][][][][][][][][][][][][][][][][][][][][CA.CDS::[email protected]: Enter IXPSObjectV1::getValueCount]

Do you know what these log messages are for and can they be suppressed?

 

Environment

Release : ALL

Component : SITEMINDER -POLICY SERVER

Cause

XTrace was enabled via XPSConfig.

Resolution

Use XPSConfig to disable Xtrace.

Additional Information

In this particular customer's case, the XTracing did not stop until we made an unrelated change to the policy server trace configuration, and then reverted that change.  This step should not have been necessary, but we are documenting it here in case it occurs elsewhere.