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We upgraded NFA to 10.0.4 and the performance Center 20.2.3 is not showing data in the Administration for Netflow view

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Article ID: 203352

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After upgrade the NFA tool to 10.0.4, In Performance Center I can see it is showing the collected information, there are no issues in that topic,

But when I go to the Administration option for Netflow in Performance center all the options are empty.

Administration ->Datasource-> Network flow analysis

..

 

Environment

Release : 20.2

Component : IM Reporting / Admin / Configuration

NFA 10.0.4

Cause

We see this error in the PCService.log

 

INFO   | jvm 1    | 2020/11/13 10:13:25 | ERROR | qtp327517260-6302        | 2020-11-13 10:13:25,289 | com.ca.im.portal.plugins.reporteranalyzer.models.RAFormSettingsModel

INFO   | jvm 1    | 2020/11/13 10:13:25 |       | Error fetching accessible discovered devices values.

INFO   | jvm 1    | 2020/11/13 10:13:25 | com.ca.im.portal.plugins.reporteranalyzer.utils.RAWebServiceException: Web Service Response Error - URL: http://NFA-HOST-IP:8981/odata/api/applicationSettings?SsoToken=P1E-wpnjFR-DTpN6BGp7ty93ddUn-DzfmRTy_randomstuffTdbMN8j9-OIQauU8s1Bg* - httpResponseCode: 401

INFO   | jvm 1    | 2020/11/13 10:13:25 |       at com.ca.im.portal.plugins.reporteranalyzer.utils.RAWebServiceHelper.extractError(RAWebServiceHelper.java:693)

INFO   | jvm 1    | 2020/11/13 10:13:25 |       at com.ca.im.portal.plugins.reporteranalyzer.utils.RAWebServiceHelper.performOperation(RAWebServiceHelper.java:93)

INFO   | jvm 1    | 2020/11/13 10:13:25 |       at com.ca.im.portal.plugins.reporteranalyzer.models.RAFormSettingsModel.getSettingsInfo(RAFormSettingsModel.java:58)

INFO   | jvm 1    | 2020/11/13 10:13:25 |       at com.ca.im.portal.plugins.reporteranalyzer.models.EditApplicationSettingsModel.initialize(EditApplicationSettingsModel.java:99)

 

And if you click the NFA link below it prompts for credentials instead of passing straight through to NFA:

..

 

Resolution

Remote to the NFA console server

Explore to *\NFA\Portal\SSO\bin

Double click SsoConfig

2- Ca Network Flow Analysis

4 - Single Sign-On

See the value for

Encryption Decryption Key : #$utT9%

Now choose option 1 for Remote Value

And again check the

Encryption Decryption Key : RN1TG9IK

 

If they do not match that is the cause of the problem.

STEPS TO RESOLVE

Apply the patch attached to this techdoc - NFA_10.0.4_PTF_003.zip

   Be sure to follow the read-me

Do a full synch on the NFA data source in CAPC.

Launch ssoconfig on NFA,

2- Ca Network Flow Analysis

4 - Single Sign-On

2 - Local Override

7 - Encryption Decryption Key

And choose r for reset.

Wait a few minutes and see if the NFA admin views are now populated in CAPC.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/network-flow-analysis/10-0-0/installing/initial-configuration/enable-https-for-ca-network-flow-analysis.html

 

Attachments

NFA_10.0.4_PTF_003_1605308712456.zip get_app