Messages stay in the message queue with the remote MTA responding with SMTP code 452 - Too many recipients received this hour.
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Messages stay in the message queue with the remote MTA responding with SMTP code 452 - Too many recipients received this hour.

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Article ID: 203291

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Messages stay in the message queue with the remote MTA responding with the SMTP code 452 - Too many recipients received this hour.

Environment

SMG 10.7.3 and later

Cause

Large amount of messages to the same remote domain MTA.

Resolution

This is commonly called grey-listing. When you send too many e-mails (or more often - a certain number of e-mails where a recipient does not exist) a destination mail server does not black list you, but instead they temporarily block access from your mail server (likely the IP address of your mail server). Usually this block is set for 1 hour but obviously can vary depending on the configuration.

You can do several things:
a. Contact the admins of the domain in question and request your IP address to be whitelisted. (3rd party outside of our control.)
b. Check/increase time e-mails can stay in your local queues (to have more chances of them to retry and finally get delivered.
c. Add more public IP addresses to your server.