search cancel

Testing actions return: Failed - Test failed.

book

Article ID: 203264

calendar_today

Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

Trying to run a test action (any action) against an agent (any agent) results in:

Failed

Test failed.

Result:

Test failed

Environment

Release : 6.6

Component : CA Release Automation Release Operation Center

Cause

This has been seen to happen when the database thinks it has a different version of certain action packs. This might happen if, for example, you attempted to upgrade to one version and then rolled back the management server. But not the database. To verify if this is the case, open ROC -> Administration -> Action Management. Select the "Installed Packs" page and review the action packs. If you're getting this error while using a delay or "run command line" action then these actions are associated with the following action pack files:

  • nolio-actions-<version>.jar
  • nolio-actions-files-<version>.jar
  • nolio-actions-security-<version>.jar
  • nolio-actions-shared-<version>.jar
  • nolio-rc-actions-<version>.jar

In the Action Managemnet -> 'Installed Packs' view you should see that the version of these files match the version of your Nolio installation. If not then this is the problem. If the version is the same then this article might not apply to your situation. Please open a support issue if the versions for the files above are the same as the version of Nolio you are using. Ex: 6.6.0, 6.7.0

Resolution

The recommended way to resolve this issue is to rollback your management server, your repository server (if it is not on your management server) and your database to the same restore point. This way all of your mgmt server files, repo files and database entries will be in sync. 

 

If the rollbacks are not an option then you may be able to restore these files from your repository. But this depends on whether your repository server was on the management server or on a remote server. If your nexus repository server is on a remote server than these files may have been overwritten. To check:

  1. Login to your nexus repository (http://nexusrepo-servername:8080/nexus)
  2. Access the nolio-actions repository
  3. Expand core_actions_group. Then expand each of folders/version for the files: 
    • nolio-actions
    • nolio-actions-files
    • nolio-actions-security
    • nolio-actions-shared
    • nolio-rc-actions
  4. If the version you need is available then you can right click on it's jar file and Download. 
  5. Once each of the files are downloaded then you can go back to the ROC -> Administration -> Action Management -> Installed Packs page and click on Import. Import each file. This should get the files back onto the management server - making them available to agents when an action is run.
  6. Run the test action again. 

Additional Information

Some other ways that you might be able to confirm whether or not this type of problem is happening in your environment:

One:

Try to sync your management server and repository via JMX using: noliocenter:type=info -> syncWithRepository (false) -> Invoke

This might return an INFO message similar to the following (in your nolio_dm_all.log):

Action pack [/nexus/content/repositories/nolio-actions/default_actions_group/nolio-entities-shared/6.7.0/nolio-entities-shared-6.7.0.jar] was not found in the default repository [http://nexusrepo-servername:8080/nexus/content/repositories/nolio-actions]. response was [HTTP/1.1 404 Not Found]

If the version of Nolio you're running is 6.6.0 then this is a problem and this article applies. 

 

Two: 

While trying to run the test/action the agent's nolio_all.log file shows DEBUG messages like these:

  • - removing action [nolio-actions-6.#.#.jar] from disk
  • - removed action [nolio-actions-6.#.#.jar] from disk successfully
  • - removed action [nolio-actions-6.#.#.jar] from in-memory cache.

 

Three: 

Look in the actionslib folder on your management and agent server. If the files described above cannot be found then they've been removed because they're out of sync with what the database thinks the system/environment should have and this article applies.