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Extremely slow login/load times for fresh 20.3 OC using either local or ldap account

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Article ID: 203248

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After submitting either local or ldap credentials at the login/splash screen for a fresh installation of 20.3 Operator Console, it is taking between 2 - 6 minutes to process and proceed to drawing the OC home page. Once the home page populates, response seems reasonable, it is just the initial authentication that is taking an extremely long time. This happens across Firefox and Chrome browsers, for both LDAP and local realm users.

Environment

Release : 20.3

Component : UIM - OPERATOR CONSOLE

Cause

- need for cabi uninstall and reinstall

Resolution

Verify existing instance of cabi was removed.

Please refer to:

How to Uninstall / Reinstall Bundled CABI
See: https://knowledge.broadcom.com/external/article?articleId=97227

To uninstall cabi:

1.In the IM or Admin Console delete cabi & wasp probes (or leave wasp if it does not have \webapps\cabijs)

2.Delete these folders from disk:

   $\Nimsoft\c
   $\Nimsoft\probes\service\cabi
   $\Nimsoft\probes\service\wasp (or leave as mentioned above)

3.Run the DROP tables
(at \Program Files (x86)\Nimsoft\probes\service\cabi\config\scripts\drop_tables\1.2\sqlserver (assuming an sql server db)


4.Deploy wasp

- open OC wasp configure 
- go to Setup tab, Probe Address, and copy the value for data_engine
- click cancel
- open cabi wasp configure 
- go to Setup tab, Probe Address, and past the value for data_engine
- click OK
- activate wasp 

5. Verify cabi robot has security certificate.pem file and robot.cfg has been updated with its location.

6. Deploy CABI 4.2 on a robot

7. Once the deployment is completed, it will show the "local" keyword reference error. Then on the CABI robot, Navigate to:

"../probes/service/wasp/webapps/cabijs/WEB-INF/applicationContext-virtualdatasource.xml" and changed the keyword from "local" to "bean"

8. Navigate to the OC robot's  "../probes/service/wasp/lib/services" folder, and copy "groovy-all-2.4.7.jar" file and place it in CABI robot's "../probes/service/wasp/webapps/cabijs/WEB-INF/lib" folder. And remove the existing "groovy-all-2.4.5.jar" file from this location and restart the CABI robot.

9. After the CABI robot restart, you should be able to access CABI through it's URL.

   http://<cabi robot>:80/cabijs 

Login Domain is left blank and superuser is both the user name and password.

10. Deploy CABI 4.3 probe on to the CABI robot which should work fine and you should be able to access the latest CABI server(4.3).

11. Redeploy these packages to the cabi robot:

    - uim_core_dashboards_pack
    - uim_unified_reporter_pack

12. Disable the below flags related to same-site cookie

enter url chrome://flags 

- SameSite by default cookies
- Enable removing SameSite=None cookies
- Cookies without SameSite must be secure
- For Microsoft Edge browser, also disable Schemeful Same-Site 

These last two steps and others are documented at:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-3/installing/ca-business-intelligence-with-ca-uim/installing-and-upgrading-ca-business-intelligence-jasperreports-server-with-ca-uim/install-or-upgrade-for-a-bundled-ca-business-intelligence-jasperreports-server.html#concept.dita_c2a97a88c62cb3b239ae19b62fa62638ef4156bf_Troubleshooting

After the above process was completed, the slowness issue no longer occurred.