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NASS Down error in oi_connector probe log file

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Article ID: 203232

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Updated On:

Products

DX Operational Intelligence

Issue/Introduction

In our AIOps environment with DX OI 20.2 on premise and UIM 20.3, we do not get UIM metrics via oi_connector probe version v1.38. The UIM alarms are forwarded correctly.

We are not sure about the NASS configuration. The "Validate NASS Connection" gives back error "NASS url is unavailable. :401". Same error can be found in probe log.

Excerpt from oi_connector.log:
Nov 10 16:10:56:257 [DOI_MONITOR_THREAD, oi_connector] Starting nass monitoring
Nov 10 16:10:56:257 [DOI_MONITOR_THREAD, oi_connector] Inside validateResponseFromNASS()
Nov 10 16:10:56:257 [DOI_MONITOR_THREAD, oi_connector] URL provided :: https://apmservices-gateway.machine1.local/metadata/registerMetric
Nov 10 16:10:56:260 [DOI_MONITOR_THREAD, oi_connector] payload for validateResponseFromNASS : {"metrics":[{"sourceName":"dummySource","type":1,"attributeName":"dummyAttribute","attributes":{"product":"UIM"}}]}
Nov 10 16:10:56:272 [DOI_MONITOR_THREAD, oi_connector] Response Code from validateResponseFromNASS(): 401
Nov 10 16:10:56:272 [DOI_MONITOR_THREAD, oi_connector] Nass is Down. 401
Nov 10 16:10:56:272 [DOI_MONITOR_THREAD, oi_connector] Sending a Critical Alarm, as Nass URL is Down!!
Nov 10 16:10:56:273 [DOI_MONITOR_THREAD, oi_connector] Nass is Down. Counter value : 9

Following curl command gives back RC 400 instead of 401 in logfile:
curl -v -X POST -H 'Accept: application/json'  -H 'Content-Type: application/json' -H "Authorization: Bearer ${TOKEN}" https://apmservices-gateway.machine1.local:443/metadata/registerMetric --data '{"metrics":[{"sourceName":"dummySource","type":1,"attributeName":"dummyAttribute","attributes":{"product":"UIM"}}]}' --cacert /data/extracted_20_2/tls_certs/machine.local.crt

We need help to find out what is wrong with the NASS Url?

Environment

Release : 20.2

Component : CA DOI AO PLATFORM COMPONENTS

Cause

oi_connector.cfg has following value for 

nassTassToken = ........eyJ0eXAiOiNiJ9.eyJleHAiOjkyMjGciOiJFUzI1NiJ9.eyJleHAiOjkyMjMzNzIw......

Which seems to be the cause of this issue.

Resolution

Please review the following Technical Document.

https://knowledge.broadcom.com/external/article?articleId=196692

The nassTassToken has to be empty.

This article is also valid for on premise DX installation.