The Firmware Version field in the Spectrum OneClick subview of a Palo Alto device is blank
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The Firmware Version field in the Spectrum OneClick subview of a Palo Alto device is blank

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Article ID: 203114

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Updated On:

Products

CA Spectrum

Issue/Introduction

The Firmware Version field in the Spectrum OneClick subview of a Palo Alto device is blank

However, the Software Version field in the Palo Alto Network -> System Information subview in Spectrum OneClick does show the proper firmware version:

How to populate the Firmware Version field in the Spectrum OneClick subview of a Palo Alto device.

Environment

Release : Any

Component : Spectrum Core / SpectroSERVER

Cause

The problem with populating attributes like firmware and serial number is there is no standard mib-2 attribute that contains this information that can be used for all devices.

Most vendors incorporate this information in a vendor specific mib or the information like firmware is included in the sysDescr.

For firmware, what Spectrum tries to do is use a regular expression to try and extract the firmware version from information in the sysDescr. 

However, for the Palo Alto device, the firmware version is not in the sysDescr.

Resolution

For this device, the firmware version is not included in the sysDescr so we need to tell Spectrum to look at the vendor specific mib panSysSwVersion attribute id 0x6520009.

Use the instructions located in knowledge article 45787 "Spectrum NRM_RunningFirmware attribute not populating for some device models." to use the panSysSwVersion attribute id 0x6520009 for the Palo Alto device.

Additional Information

Please reference knowledge article 121348 "How to propagate catalog changes in a Distributed SpectroSERVER environment" if you need to make Model Type Editor (MTE) in a Distributed SpectroSERVER (DSS) environment.