User Not Created issue in CA Spectrum - LDAP User Group Authentication
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User Not Created issue in CA Spectrum - LDAP User Group Authentication

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Article ID: 203095

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When using the LDAP User Group Authentication feature introduced in Spectrum 10.4.2, the user attempting to login is not created.  Enabling  SSORB  Security SP debug in OneClick provides the following output in catalina.out when the user logs in:

Nov10, 2020 11:10:38.387 (http-nio-8080-exec-10) (SecuritySP) - Found match for LDAP Server user group name for the configuration user group : CN=MonitoringGroup,OU=Static,OU=DistributionLists,DC=acme,DC=net

Nov10, 2020 11:10:38.387 (http-nio-8080-exec-10) (SecuritySP) - Got LDAP usergroup name: MonitoringGroup for user name: 8675309

Nov10, 2020 11:10:38.424 (http-nio-8080-exec-10) (SecuritySP) - Found Spectrumuser group model with name : MonitoringGroup with IDs : [33796522]

Nov10, 2020 11:10:38.459 (http-nio-8080-exec-10) (SecuritySP) - Found Spectrumuser group model with name : MonitoringGroup with IDs : [67109032]

Nov10, 2020 11:10:38.462 (http-nio-8080-exec-10) (SecuritySP) - Found Spectrumuser group model with name : MonitoringGroup with IDs : [83886226]

Nov10, 2020 11:10:38.463 (http-nio-8080-exec-10) (SecuritySP) - Found Spectrumuser group model with name : MonitoringGroup with IDs : [17036282]

Nov10, 2020 11:11:18.597 (PoolThread-1: HistoricalUpdateJobPool => BackEndEventDataModel.HistoricalUpdateJob)(SLM_STAT_EVENT) - HUJob.waitForConnection (0x4000000):  recheckingArchive Man connection every 1 minute(s)

Nov10, 2020 11:11:21.690 (SRM/LandscapeManager/LandscapeThread_0) (SRM_Events)- (WARN) - Unable to obtain connection to ArchMgr for xxxxxxxxxxxxxxx. Retrying.

~

But this user '8675309' was not added to 'MonitoringGroup' which  was found.

Environment

DX NetOps Spectrum release 20.2 or later

Cause

In this example case, the DSS environment contains 6 landscapes. In the debug output however, the Spectrum UserGroup model is only found on 4 landscapes. Checking the Landscapes web page in OneClick shows one of the landscapes is found to be down.

Resolution

  1. Bring the down landscape back online.

  2. If the landscape should no longer be a part of the DSS remove the landscape from the environment and the Location Server Map

     How to remove a landscape after it has been removed from the Spectrum environment.

    In addition, if the old SpectroSERVER is still installed, change the LocationServer to point to itself as the MLS so that it does not re-publish into the MLS's location Map

    cd $SPECROOT/LS/
    edit: .locrc
    MAIN_LOCATION_HOST_NAME=<change to itself>


    kill the LocServer process if running so the change takes effect