CTAgent::GetAgentStatusEx(): CAtrsException exception, error: m_taskStatusCollector->GetTaskStatusEx failed, OS error: Invalid pointer (0x80004003), at line 1537
search cancel

CTAgent::GetAgentStatusEx(): CAtrsException exception, error: m_taskStatusCollector->GetTaskStatusEx failed, OS error: Invalid pointer (0x80004003), at line 1537

book

Article ID: 203063

calendar_today

Updated On:

Products

Client Management Suite

Issue/Introduction

CEM (Cloud Enabled Management) enabled Symantec Management Agent was communicating with the SMP (Symantec Management Platform) Server while connected to the production network, through the VPN, and when in CEM-enabled mode.  All of a sudden all communication between the Symantec Mamagement Agent and the SMP Server stopped and the agent logs were full of the following errors:

Severity: 1
Date: 11/9/2020 4:53:13 PM
Tick Count: 272023796
Host Name: <hostname>
Process: AeXNSAgent.exe (9440)
Thread: 14208
Module: client task agent.dll
Source: CAtrsException
Description: 
  CTAgent::GetAgentStatusEx(): CAtrsException exception, error: m_taskStatusCollector->GetTaskStatusEx failed, OS error: Invalid pointer (0x80004003), at line 1537

Environment

ITMS 8.x

Cause

The IIS binding of the Default Web Site for Port 443 did not have a certificate bound to it.

Resolution

Check under IIS Manager that the IIS > Default Web Site has a certificate bound to Port 443.
Once it is bound, check the client machines have started communicating again.