We have issues with how processes are performing
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We have issues with how processes are performing

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Article ID: 202950

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

We have a process that assigns an approval action item to PMs that stopped including assignees yesterday morning at 8 am... worked fine up until then and now we are hung up.
I have the process on hold because it stopped assigning assignees to an action item which breaks the functionality.

Environment

Release : 15.8.1

Component : CA PPM SAAS BUSINESS PROCESS MANAGEMENT

Cause

ERROR 2020-11-04 10:48:48,892 [Action Execution Pipeline 2 (tenant=clarity)] bpm.engine (clarity:process_admin:16793722__6FF651FA-1160-4AAD-A453-8C13201AC1FD:none) Error (will retry) caused by Step Instance: com.niku.bpm.engine.objects.StepInstance@1712e323 [Id: 6089317 Process Instance Id: 5469393 Step Id: 5049447 State: BPM_SIS_READY_TO_EXEC_ACTION Step Name: null Start Date: 2020-11-04 10:46:21.455 Expected End Date: null Percent Complete: 0.375 Warned: false Retry Count: 1 No of Pre Conditions: 1 No of Post Conditions: -1 Last Condition Eval Time: 1604515581593 Pre Condition Wait Events: null Post Condition Wait Events: null Pass Conditions: null Error Id: -1
 Process Thread: com.niku.bpm.engine.objects.ProcessThread@49f4b9ed [Id: 5469393 Parent Step Instance Id: -1 Join Step Instance Id: -1]
 Split Threads: null
 Join Threads:null]
com.niku.bpm.BpmException: com.niku.bpm.BpmException: com.niku.union.odf.lookup.LookupException: com.niku.union.persistence.nsql.NSQLException: com.niku.union.persistence.PersistenceException: 
SQL error code: 0
Error message: PooledConnection has already been closed.

Resolution

Clear Clarity cache.