Spectrum AlarmNotifier not starting with error "user denied access"
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Spectrum AlarmNotifier not starting with error "user denied access"

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Article ID: 202934

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The AlarmNotifier processes is not starting with error message "user denied access":

The problem is seen even though the following has been checked:

  • SpectroSERVER is up and running.
  • The user that is starting the Alarm Notifier is the Spectrum installation user. Before the upgrade all worked fine with the same settings. 
  • The hostname of the system where the AlarmNotifier is running is correctly added to the $SPECROOT/.hostrc file

Environment

DX NetOps Spectrum : 20.2 or later

Cause

Any of the following may cause this issue:

  1. All the files in the Notifier directory ($SPECROOT/Notifier) not having correct user ownership/permissions set.

  2. The hostname of the system where the AlarmNotifier is running is NOT in the $SPECROOT/.hostrc file of ALL the systems in the DSS.

  3. The hostnames & IP addresses are not correctly setup in the ~/etc/hosts for all the systems in this DSS

Resolution

  1. Problem due to having the files in the Notifier directory not being owned by the correct Spectrum installation user, which is used to start the Notifier process.
    Running "ls -l" command on the Notifier directory should show the files have the wrong user set.  Change that to the correct user and AlarmNotifier starts and works as expected.

  2. Add the hostname to the $SPECROOT/.hostrc files and restart the AlarmNotifier.

  3. Ensure the hostnames in the ~/etc/hosts are configured with the correct IP addresses for all the servers in the DSS. Also ensure that correct naming convention is followed, i.e, if network DNS expects Fully Qualified Domain Names (FQDN - eg: myhost.mycompany.com) or singular names (eg: just myhost), then set the hostname accordingly.