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Host data for ICMP probe is not appearing in Performance Reports Designer tool

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Article ID: 202813

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

ICMP results are not appearing in PRD. At first, we suspected that the issue is due to metric ids mismatch. But, after trying to repopulate the metric ids in s_qos_data table - there was no corresponding metric id in cm_configuration_item_metric table even when ci_metric_id was repopulated in s_qos_data. 

Environment

UIM 20.1
robot 9.30
hub 9.30

Cause

Issue was partially with Discovery Server. And, some other data corruption occurred when Customer cloned an older Server for the UIM.

Resolution

We followed the KB: UMP - No metrics available displayed for many nodes

  - and the ci_metric_id mappings looks to be corrected. But, still PRD was not working where as dashboard designer is showing data right from the bringing.

Customer cloned Server for the UIM and that has caused this issue as well, which should be resolved after following these steps:

  1. set <setup>/update_metric_id = yes on data_engine probe.
  2. Update data_engine probe's configuration with following configuration and restart the data_engine probe: <setup>/update_metric_id = yes. This configuration will force the data_engine to update the met_id if it has changed.
  3. Clear the nis_cache of the robot include .robot_device_id and restart the robot.
  4. Update ci_metric_id to null for the problematic device's QoSes and restart the data_engine 
  5. Restart the discovery_server to pick up new niscache elements.