search cancel

ASA for WebLogic 8.1

book

Article ID: 202761

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

 

We're running an old WebLogic server and we'd like to know which
version of ASA Agent is compatible with Policy Server 12.8SP3 ?

We run WebLogic 8.1.

 

Environment

 

Policy Server 12.8SP3 on RedHat 6

 

Resolution

At first glance, according to our Support Matrix, we offer no version
of ASA Agent certified on WebLogic 8.1 :

  CA Single Sign-On 12.7 Application Server Agents, includes updates for base release and all later CRs/SPs for this release
  https://ftpdocs.broadcom.com/phpdocs/7/5262/5262_12-7_ASA_PSM.pdf

  SiteMinder 12.0 Application Server Agents, includes updates for base release and all later CRs/SPs for this release
  https://ftpdocs.broadcom.com/cadocs/0/contentimages/SiteMinder_ASA_12_0%203September2020.pdf

  SiteMinder 6.0 Application Server Agents, includes updates for base release and all later CRs/SPs for this release
  https://ftpdocs.broadcom.com/phpdocs/7/5262/5262_ASA_PSM.pdf

More, WebLogic 8.1 is Out of Support as even version 9 is EOL from
December 2009 :

  ORACLE FUSION MIDDLEWARE 

    | Release                        | GA Date  | Premier      | Extended     | Sustaining   |
    |                                |          | Support Ends | Support Ends | Support Ends |
    |--------------------------------+----------+--------------+--------------+--------------|
    | Application Server 10g (9.0.4) | Dec 2003 | Dec 2006     | Dec 2008     | Dec 2009     |

    p.8

  https://www.oracle.com/us/assets/lifetime-support-middleware-069163.pdf

We strongly suggest you to use the latest ASA Agent with WebLogic
12cR2 64bit as stated by our Support Matrix :

  CA Single Sign-On 12.7 Application Server Agents, includes updates for base release and all later CRs/SPs for this release

    | CA SINGLE  | APPLICATION    | WIN      | RED      | RED      |
    | SIGN-ON    | SERVER         | 2012     | HAT      | HAT      |
    | APPLICATIO | VERSION        | SP2      | 6.x      | 7.x      |
    | N SERVER   |                | (64 bit) | (64 bit) | (64 bit) |
    | AGENT      |                |          |          |          |
    |------------+----------------+----------+----------+----------|
    | Weblogic   | Oracle         | Yes      | Yes      | Yes      |
    | ASA 12.7   | Weblogic       |          |          |          |
    |            | 12cR2          |          |          |          |
    |            | (12.2.1.x - 64 |          |          |          |
    |            | bit)           |          |          |          |

    p.1

  https://ftpdocs.broadcom.com/phpdocs/7/5262/5262_12-7_ASA_PSM.pdf

Finally, for your information, ASA Agents 6.0 are still supported with
Policy Server 12.8SP3 as stated by the Support Matrix 12.8 :

4.1 Policy Server and Agents Compatibility

  Any 6.x versions of Web Agents, Access Gateways (previously called
  Secure Proxy Server), ERP Agents, ASA Agents, and 5.x versions of
  ERP Agents that are not beyond their end-of-service date do not
  support IPv6 or FIPS Mode (and can only connect to 12.8 Policy
  Server in FIPS Compatibility Mode).

https://ftpdocs.broadcom.com/cadocs/0/contentimages/Symantec%20SiteMinder_12_8_Platform%20Support%20Matrix_18September2020.pdf