Automation agent unable to connect to Notification Server with error: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider (0x800B0109)
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Automation agent unable to connect to Notification Server with error: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider (0x800B0109)

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Article ID: 202743

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Updated On:

Products

Deployment Solution

Issue/Introduction

The customer is unable to run tasks and register to the Notification Server after booting to a pre-boot environment. The following error may be seen:

*WARN Server Connection: Failed to connect to NS server, retrying in a minute, error: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider (0x800B0109)

Environment

ITMS 8.x

Cause

Invalid certificate was used in the Agent Communication Profile and IIS binding for port 443.

Resolution

Check the following:

1. Go to Agent Communication Profile (under SMP Console>Settings>Agents/Plug-ins>Symantec Management Agent> Symantec Management Agent Communication Profiles) and check if the certificate is a valid one. 

Note: If it is an environment that is not setup completely for HTTPS communication, just uncheck "HTTPS communication hosts" box so only HTTP information is provided to the client machines).

2. Go to IIS manager and make sure the proper certificate is assigned to the port 443 binding.

3. After the proper certificate is been added to your Agent Communication Profile and Default Web Site binding, navigate to Settings>Deployment>Manage Preboot configurations. Verify and 'Apply' the changed communication profile under Settings>Profile to be used for Notification Server connection so the proper certificate can de added. Once the profile has been applied, 'recreate' preboot configurations to apply the change.