Logmon probe - "Mode" is not working as expected
search cancel

Logmon probe - "Mode" is not working as expected

book

Article ID: 202735

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We have a tested a file on customer server to trigger an alert for any number expect 1. The file always has a number at starting of the file as in screenshot. We are using Reg Exp /[0]|[2-9]/ to match number except 1, Alerts are not triggered as we tried using different Mode : Cat, Updates and full.

It seems like it is not scanning the file from the starting of the file every time we tested, Sometimes alerts trigger if we update the 0 after some lines added with random characters before to this line.

Environment

Release : 20.1

Component : UIM LOGMON

Cause

- logmon configuration

Resolution

Please download and deploy the logmon v4.11-T3. You can get this from support.

Then make sure you have File Encoding set to UTF-8 and it should work.

During testing in the lab it worked for me.