Problem creating Jasper Profile
search cancel

Problem creating Jasper Profile

book

Article ID: 202597

calendar_today

Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When click "Launch Insights" button from Insights tab, you see error "AHD04405: Internal error of the CA Service Desk Manager system" and check the stdlog you see messages 

ERROR freeaccess.spl 45236 Problem creating Jasper Profile. Error: Exception occurred while creating user

ERROR session.c 9978 Cancelling session servicedesk-627687340:0x3971940 due to interpreter error Problem creating Jasper Profile. Error: Exception occurred while creating user Problem creating Jasper Profile. Error: Exception occurred while creating user

and then you follow steps in tech doc Launch button for Insights (CABI JasperReports) not working on Service Desk copy casm_insights.jks , casm_insights.properties files to Service Desk \site folder and recycle Service Desk. But problem persists...what could be the reason?

Environment

Release : 17.x

Component : JASPERSOFT REPORTS FOR SERVICE MANAGEMENT

Cause

The Insights protocol setting is wrong while you use https for Jaspersoft, your insights.jasper.protocol remains as HTTP.

Resolution

To correct this issue, follow these steps:

--log into SDM web interface as Administrator

--then Administration-->xFlow Interface-->General and click on "show filter" button and enter in configuration key field "insights.jasper.protocol" and search 

--edit this parameter change it to HTTPS and save

--go to Insights tab and click on "Launch Insights" button again