CA CSM Error: The product version that you are installing or a newer version of the product is already installed in this zone.
search cancel

CA CSM Error: The product version that you are installing or a newer version of the product is already installed in this zone.

book

Article ID: 202505

calendar_today

Updated On:

Products

COMMON SERVICES FOR Z/OS Common Services CHORUS SOFTWARE MANAGER

Issue/Introduction

While trying to install CETN600 "CA CSM COMMON SERVICES FOR V6.0" under CCS 15.0  I ran into a space issue (Abend E37) with the CAW0EXP target dataset.

The necessary steps were taken to re-allocate a larger CAW0EXP target dataset. This was done outside of CA MSM control.

Returned to CA MSM and attempted to install CETN600 again. However the following message was presented:

"The product version that you are installing or a newer version of the product is already installed in this zone. Select a different target zone to continue the installation, or exit the wizard"

At this point the only option is to go back or cancel. 

Not sure if it matters, but it looks like the install datasets are still available on DASD. 

CAI.CCS.R1500.CETN600.F1
CAI..CCS.R1500.CETN600.F10
CAI..CCS.R1500.CETN600.F2
CAI..CCS.R1500.CETN600.F3
CAI..CCS.R1500.CETN600.F4
CAI..CCS.R1500.CETN600.F5
CAI..CCS.R1500.CETN600.F6
CAI..CCS.R1500.CETN600.F7
CAI..CCS.R1500.CETN600.F8
CAI..CCS.R1500.CETN600.F9

What is the best way to resolve this issue?

Environment

Release : 6.0
Component : Chorus/Mainframe Software Manager

Release: 15.0
Component: CA COMMON SERVICES

Cause

Due to the Abend E37 and failure to install, the back-out of the install was incomplete. This left the SMPCSI with a failed CETN600 install.

This explains why the CETN600.F* relfiles remain allocated.

Resolution

Query the SMP CSI and check what it shows for SYSMOD CETN600. If showing RECEIVED and APPLIED IN ERROR, run the below sample SMP job outside of CA MSM to remove CETN600 from the GLOBAL and TARGET zones. Then refresh the CSI in CA MSM and check that CETN600 no longer shows as an installed product in the Common Services CSI.

After the above is done, the install should complete successfully.

//*********************************************************************
//*            SMP/E DELETE  FUNCTION                                 *
//*********************************************************************
//*
//SMPE     EXEC PGM=GIMSMP,REGION=0M,PARM='DATE=U'
//*
//SMPCSI   DD DISP=OLD,DSN=your.smpe.CSI
//SMPLOG   DD DUMMY
//SMPHOLD  DD DUMMY
//SMPPTFIN DD *
++FUNCTION (DCETN60).
++VER (Z038) DELETE(CETN600).
/*
//SMPCNTL DD *
  SET BDY(GLOBAL).
  RECEIVE S(DCETN60
                   ).
  SET BDY(CAIT0).
  APPLY S(DCETN60
                 ).
  SET BDY(CAID0).
  ACCEPT S(DCETN60
                  ).
  SET BDY(CAIT0).
  UCLIN.
   DEL SYSMOD (CETN600).
   DEL SYSMOD (DCETN60).
  ENDUCL.
  RESETRC.
  SET BDY(CAID0).
  UCLIN.
   DEL SYSMOD (CETN600).
   DEL SYSMOD (DCETN60).
  ENDUCL.
  SET   BOUNDARY(GLOBAL) .
   REJECT HOLDDATA NOFMID DELETEFMID(CETN600,DCETN60).
/*
//