search cancel

Using DigiCert SSL during Recording throws the error in DevTest Portal

book

Article ID: 202494

calendar_today

Updated On:

Products

CA Cloud Test Mobile CA Application Test

Issue/Introduction

Sometimes, Customers would like to leverage a DigiCert SSL certificate during the creation of a recording/VS through portal and get the error  "Your recording session has become invalid because of the following error: Recording session not found: 7330A623188F11EBBA1A005056819135. Your recording session will be reset." but when Click ok the keystore validates fine. See the below screenshot.

 

Environment

Release : 10.6

Component : CA Service Virtualization

Cause

The issue was caused because the Keystore used that had a private key entry with alias name "1" which caused the problem,. The Alias name of keystore used with recorder should have min 3 characters.

 

Resolution

Updating the alias using the below keystool changealias command, the problem will be resolved. 

"c:\Program Files\Java\jdk1.8.0_241\bin\keytool.exe" -changealias -alias sslcert -destalias sslsert_new -keystore newkeystore.jks

Attachments