Cannot start the Symantec DLP Detection Server Service
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Cannot start the Symantec DLP Detection Server Service

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Article ID: 202369

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Updated On:

Products

Data Loss Prevention

Issue/Introduction

The "Symantec DLP Detection Server Service" will not start on the Detection Server.
Manually trying to start the service results in a Windows 1503 error.

"Windows could not start the Symantec DLP Detection Server Service on Local Computer.
Error 1503: The service did not respond to the start or control request in a timely fashion."


Environment

Data Loss Prevention 15.5 MP2

Cause

Permissions were missing on the C:\ProgramData\Symantec directory.

Resolution

Verify the Logon user has permissions to the DLP install directories.

On the Detection server:
1. Go to Start > search > type: services.msc > select the Services application.
2. Once the Services application opens, scroll down to the "Symantec DLP Detection Server Service". Note which user has been set as the Logon user.
3. Open File Explorer and navigate to the Symantec DLP install directories.

Default directories are:
C:\Program Files\Symantec
C:\ProgramData\Symantec

4. Right click on the Symantec folder > Properties >  Security tab. Verify that the Logon user is listed and they have all "allow" permissions. 

Additional Information

Additional items to check in order to verify this issue:
1. Checking the SymantecDLPDetectionServer.log, there are no entries logging the attempt to start the service.
2. Event Viewer > Windows Logs > Application, shows a permissions error for the Symantec DLP directories.