"baseline_engine.QOS_MESSAGE" queue is backed up with messages
search cancel

"baseline_engine.QOS_MESSAGE" queue is backed up with messages

book

Article ID: 202341

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

"baseline_engine.QOS_MESSAGE" queue is always backed up on the Primary hub even after the queue is manually emptied.

Example of alarm message

The queue 'baseline_engine.QOS_MESSAGE' is 836 MB. Check the hub configuration.

Environment

Release : 9.02, 9.20, 20.1, 20.3

Component : UIM - BASELINE_ENGINE

Cause

This issue is sometimes seen if get queues are manually created for the baseline_engine probe.

Note: baseline_engine.BASELINE_CONFIG and baseline_engine.QOS_MESSAGE queue messages are automatically sent to the Primary hub without the need of configuring get queues.

Resolution

1. Deactivate the baseline_engine probe

2. Configure the hub probe, select the Queues tab, and delete the attached baseline_engine queues, e.g., the baseline_engine.QOS MESSAGE and baseline_engine.BASELINE_CONFIG queues

3. Delete the get queues for baseline_engine.BASELINE_CONFIG and baseline_engine.QOS_MESSAGE on the Primary hub 

4. Delete the baseline_engine probe and its home folder under the probes\slm folder

5. Redeploy the  baseline_engine probe