search cancel

Supported JAVA JDK version for Agent for Sharepoint.

book

Article ID: 202311

calendar_today

Updated On:

Products

CA Single Sign On Agents (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign-On

Issue/Introduction

Supported JAVA JDK version for Agent for Sharepoint.

Customer is trying to install a new "Agent for Sharepoint" server and would like to know what is the supported JAVA version for Sharepoint Agent.

Environment

Version: spagent-12.52-sp01-cr10-win32

Resolution

------ Documentation Reference -------

Documentation prerequisites here:

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/single-sign-on-agent-for-sharepoint/12-52sp1/installing/prerequisites.html#concept.dita_2f18cbbfd4f6a0d95599717be079c0c4b18b7201_GeneralPrerequisites

Documentation says "A 32-bit Java Development Kit version 1.6.0_16 or higher is required on the Single Sign On Agent for SharePoint system."

------ As per the documentation we are supporting " A 32-bit Java Development Kit version 1.6.0_16 or higher (" Release 16 or higher on 1.6 version 32 bit ") is required on the Single Sign On Agent for SharePoint system.

------ But Oracle Java SE 6 and also Java 7 has reached their end of life and there is no Extended Support contract available for Oracle 6.

------ Customers would like to use a fully supported (not deprecated) alternative, like Oracle Java 8 or OpenJDK with the latest sharepoint agent-12.52-sp01-cr10 release?

----- Solution ------

As per the SE Engineering, customers can use Java 1.8 (32 bit) version (Oracle or OpenJDK) with the latest 12.52 SP1 CR10 release.

Additional Information

Kindly check the " DE481043 " for reference.