UIM CABI Dashboards stop working after sometime
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UIM CABI Dashboards stop working after sometime

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Article ID: 202267

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Environment: UIM with a database instance on MS SQL Server Always On availability group

Problem: Cabi Dashboards work fine but fails after sometime with the following error on the cabi robot wasp.log:

Cannot create PoolableConnectionFactory ([TibcoSoftware][SQLServer JDBC Driver][SQLServer]The target database, 'CA_UIM', is participating in an availability group and is currently not accessible for queries. Either data movement is suspended or the availability replica is not enabled for read access. To allow read-only access to this and other databases in the availability group, enable read access to one or more secondary availability replicas in the group.  For more information, see the ALTER AVAILABILITY GROUP statement in SQL Server Books Online.)

Environment

Release : UIM 20.3/20.4

Component : UIM - CABI

Cause

This issue is sometimes seen when the CABI UIM Datasource and UIM JNDI Datasource is configured with the node name instead of the SQL Server listener name.

Note: CABI dashboards will work until the database fails over to the alternate node.

Resolution

1. Log in directly to the CABIJS portal with superuser and edit the UIM Datasource - Replace the SQL Server node name with the SQL Server listener name

2. To update the connection properties for the UIM JNDI Datasource, edit the  ...Nimsoft\probes\service\wasp\webapps\cabijs\META-INF\context.xml and replaced the SQL Server node name with the SQL Server listener name.

3. Deactivate and Activate the wasp probe on the cabi robot