CA TDM cloned server failed to authenticate
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CA TDM cloned server failed to authenticate

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Article ID: 202252

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Since all our servers etc. need to be migrated, as per our plan, we have cloned the current server into a new device.
The repository also has been replicated to a new SQLserver.

The cloned server is accessible, and as per the below article, we also changed its Application.properties  in conf directory. 
How to reconfigure TDM Portal to point to a different DB server for the GTREP
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=202252

After changing the application property, the server is able to invoke.
However, it fails to authenticate any user/s. I have tried all IDs including administrator and my own ID which is working. 



Environment

Component : CA Test Data Manager

Cause

Client did not update the application.properties file with the new server host name.

Resolution

Please add below changes in TDM:


1) You had cloned the entire TDMPortal machine to a new server with a new hostname and IP address.
2) you corrected the application.properties file to point to the new SQL SERVER and the new gtrep that was created and this was working correctly.
3) however in the application.properties file the hold server hostname of <OLDSERVERNAME>was still present.
example:
tdmweb.connectionProfileService.address=<OLDSERVERNAME>
to 
tdmweb.connectionProfileService.address=<NEWSERVERNAME>
4) we did a search and replace for the old hostname and replaced it with the new name.
5) we stopped the oriendb and portal services and then started them.
6) we were then able to login as expected with both users.