SMGR Dialog shows blank screen, Unable to start agent from smgr | U00022028 ... UC4.smd
search cancel

SMGR Dialog shows blank screen, Unable to start agent from smgr | U00022028 ... UC4.smd

book

Article ID: 202176

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

When running the service manager (smgr), the smgr is unable to start any processes and none show up in the list in the service manager dialog

The log file shows the following:

U00022025 The file '[full path to service manager directory]\bin\UC4.smd' containing the definitions will be opened and interpreted.
U00022028 Unable to open file '[full path to service manager directory]\bin\UC4.smd', error code: '2'
No such file or directory

U00022028 Unable to open file ./uc4.smd, error code: '2' No such file or directory
U00022028 Unable to open file ./uc4.smc, error code: '2' No such file or directory
nohup: failed to run command `./ucybsmgr`: No such file or directory

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

The UC4.smd file is unavailable either because it does not exist or permissions do not allow for reading

Resolution

Possible solutions:

  • Re-download the smgr from downloads.automic.com and re-install, confirming that the UC4.smd file is the smgr /bin directory
  • Copy the UC4.smd file from an existing smgr installation
  • check the path where you try to run the command is correct and the file is in the folder
  • check if there is a file locked (with extension .lck) related to the problem (remove it if needed)