exchange_monitor probe - MSC Exchange Monitor is unavailable
search cancel

exchange_monitor probe - MSC Exchange Monitor is unavailable

book

Article ID: 201908

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I want to configure MS exchange servers via MCS template in UMP, but Exchange Monitor is grayed out and I see this message:

'Profile Type unavailable because the exchange_monitor probe is not in the local archive, does not have a valid license, or is missing other dependencies.'

I have verified pre-requisites are installed:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/exchange-monitor-microsoft-exchange-monitoring/exchange-monitor-mcs-profile-type-configuration.html

Environment

Release : 8.51 and above

Component : UIM - MON_CONFIG_SERVICE

Cause

The issue could happen if there are missing dependencies

Resolution

Please perform the following actions:

  • Through Infrastructure Manager console or Admin Console go to the Hub Server
  • Launch the probe utility on automated_deployment_engine probe
  • Select callback on archive_is_package_deployable
  • Type under name: exchange_monitor
  • Click on the play icon ‘’ to send command request 
  • Ensure the Command status returns OK (Command status should not return ‘missing’)
  • Install all the missing dependencies you see in the Command output
  • As an example, from my lab server, you can see, I am missing only one dependency, vs2008_redist_x86 package:

  • Therefore, to resolve my issue, I deployed vs2008_redist_x86 on the same robot as the exchange_monitor probe
  • Similarly install all the missing dependencies you see in your Command output on the same robot as the exchange_monitor probe

Additional Information

To access the probe utility in Infrastructure Manager (IM)

    • Go to Hub, select the automated_deployment_engine probe and press the key combination Ctrl+p

To access the probe utility in Admin Console (AC) 

    • browse to the hub’s automated_deployment_engine probes
    • click the ellipses next to Hub
    • Select "View Probe Utility in New Window"

Note:

The issue could happen to any template probe like exchange_monitor, cdm, sharepoint, iis. In this technical document we have discussed about exchange_monitor probe. Replace exchange_monitor probe with any other template probe if you are facing a similar issue in the solution