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Process Bottlenecks Portlet - Error 500 on MSSQL Database

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Article ID: 201895

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When entering a process, the following error is shown:
Error 500 - Internal Server Error. The server could not retrieve the document due to server-configuration or other technical problems. Contact your site administrator.

The APP logs show error 2 possible errors:

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Caused by: java.sql.SQLDataException: [CA Clarity][SQLServer JDBC Driver][SQLServer]Arithmetic overflow error converting varchar to data type numeric.

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ERROR 2020-10-18 11:26:39,605 [https-server-xxxxx-xx.xxx.xx.xxx-443-exec-xxx] dal.NSQLClient (clarity:user:session:npt.gridFilter) Unable to retrieve NSQL cube.  NSQLException was thrown.
com.niku.union.persistence.nsql.NSQLException: com.niku.union.persistence.PersistenceException: 
SQL error code: 16915
Error message: [CA Clarity][SQLServer JDBC Driver][SQLServer]A cursor with the name 'c_action' already exists.
Executed:

Steps To Reproduce:

  1. Create a process, based on the object Cost Plan, with start option ondemand.
  2. Create Step to send an action item to a user, e.g. Administrator.
  3. Create Finish Step.
  4. On a project, create a cost plan and on the Process tab, click Available and select the created process. Do not approve the action item.
  5. On same cost plan, create another process instance. Again, do not approve the action item.
  6. Go to the Process Bottlenecks portlet and select the created process and click filter.
  7. Do not approve the action item and navigate to Process Bottleneck an select on the created process.

Actual Results: Error 500 - Internal Server Error. The server could not retrieve the document due to server-configuration or other technical problems. Contact your site administrator.
Expected Results: There should not be an error.

Cause

This is reported as DE58862.

Resolution

This issue is fixed in Clarity 15.9.1.

Attachments