Network Prevent for Web Detection Server stuck in starting state in Enforce Server
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Network Prevent for Web Detection Server stuck in starting state in Enforce Server
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Article ID: 201704
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Updated On: 12-16-2021
Products
Data Loss PreventionData Loss Prevention Network Monitor and Prevent for Web
Issue/Introduction
In the Enforce Server you see your Network Prevent for Web Detection Server stuck in 'starting' state.
Recycling the service does not resolve the issue
Checking in the boxmonitor logs on the Detection Server you can see that the FileReader is the service that is failing to start
The FileReader logs contain references to an ICAP trace folder that cannot be found
Environment
Release : 15.x
Cause
ICAP trace has been set to 'true' in the Detection Server settings but the folder for the ICAP trace files has been deleted or moved.
Resolution
Recreate the directory referenced in the FileReader logs on the affected Detection Server.
Review the server settings for the Network Prevent for Web server(s) in the Enforce console: Icap.EnableTrace should only be set to true during troubleshooting. Leaving it in this state will cause all incoming web traffic to be captured to files in the folder defined in the Icap.TraceFolder setting until the disk is full.
The FileReader will fail to start if that folder is not present and the Icap.EnableTrace = true.
After making the changes, restart the Detection Server service.