search cancel

UIM 20.3 cabi 4.30 deployment fails - Keystore errors

book

Article ID: 201551

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Deploying bundled cabi to its robot, the deployment fails and cabi has a red status. 

Cause

Errors such as the following may be seen in the cabi.log:


Oct 15 13:52:20:636 [Thread-1, cabi]      [exec] [create-ks] Caused by: java.lang.Exception: Keystore may have been tempered with. 
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks]  at com.jaspersoft.jasperserver.crypto.KeystoreManager.a(KeystoreManager.java:621) 
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks]  ... 63 more 
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks] java.lang.RuntimeException: java.lang.Exception: Keystore may have been tempered with. 
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks] -- properties location = C:\Windows\system32\config\systemprofile\.jrsksp -- 

or

Oct 15 13:52:20:636 [Thread-1, cabi]      [exec] [create-ks] WARNING: a new encryption key and a new keystore are about to be created.
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks]  ERROR KeystoreManager:409 - failed to write keystore to C:\Windows\system32\config\systemprofile\.jrsksp
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks]  ERROR KeystoreManager:414 - Failed to create the keystore. Error: failed to create or upgrade the keystore
Oct 15 13:52:20:651 [Thread-1, cabi]      [exec] [create-ks] ERROR KeystoreManager:285 - Initialisation using propery file is unsuccessful. java.lang.RunTimeException: Failed to create the keystore at C:\Windows\system32\config\systemprofile\.jrsksp

You should also find that the file "C:\Windows\system32\config\systemprofile\.jrsksp" either does not exist, or exists but is 0 bytes.

Environment

Release : 4.20, 4.30

Component : UIM - CABI

Resolution

In this case you have 3 options:

Option 1

1. Try changing the credentials of the Robot Watcher to use a local administrator account instead of "Local System" or a domain user.
Windows > Services > Nimsoft Robot Watcher > Log On > This account

2.  Or change the access privileges of current local user on 'C:\Windows\system32\config\systemprofile' folder so that whichever used is credentialed as above can have Full Control over this folder. Note that sometimes this option isn't sufficient, and even using "Local System" for the credentials is not sufficient and a local administrator user must be used.

remove and redeploy the cabi probe and try again.

If it still fails after changing the above

Sometimes after changing the credentials even with a local admin you will still get the same error.  If this occurs then try these steps:

Backup and then remove the following files from on 'C:\Windows\system32\config\systemprofile' folder.
1. C:\Windows\system32\config\systemprofile\.jrsks
2. C:\Windows\system32\config\systemprofile\.jrsksp

Then redeploy cabi.

If all else fails

For unknown (as of this writing) reasons, a handful of users have found that deploying cabi 4.20 is successful and does not return the error; then the upgrade from 4.20 to 4.30 also succeeds.  

1. Completely remove CABI 4.30
https://knowledge.broadcom.com/external/article/97227/how-to-uninstall-reinstall-bundled-cabi.html

2. Backup and then remove the following files from on 'C:\Windows\system32\config\systemprofile' folder.
C:\Windows\system32\config\systemprofile\.jrsks
C:\Windows\system32\config\systemprofile\.jrsksp

3. Deploy cabi 4.20

4. Deploy cabi 4.30

 

Additional Information

The best practice for installing the cabi probe is to first deploy wasp to the cabi robot.

Then go to wasp raw configure and update setup\data_engine so it exactly matches the data_engine address as shown in the console.
Usually this can be copied from the wasp raw configure at the Operator Console robot. 

If the OC Home and Reports pages display a 'Data Access Error,' deploy these 2 packages to the cabi robot:

- uim_core_dashboard_pack 2.46
- uim_unified_reporter_pack 1.04

Please also refer to the troubleshooting section for more items to check:
https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-3/installing/ca-business-intelligence-with-ca-uim/installing-and-upgrading-ca-business-intelligence-jasperreports-server-with-ca-uim/install-or-upgrade-for-a-bundled-ca-business-intelligence-jasperreports-server.html#concept.dita_c2a97a88c62cb3b239ae19b62fa62638ef4156bf_Troubleshooting