search cancel

When using Javelin REST calls to TDM REST APIs, subsequent calls after logging in will produce Token Invalid / Token Expired error on server

book

Article ID: 201509

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Simple Javelin script with a REST call to login to the TDM Portal, and return the token.   
This token is re-used in a 2nd REST call to return all Projects.   

This works in:
4.8GA
4.9GA

 It fails on:
4.9.89
4.9.100.4 (4.9.1 GA)

with errors in the logs showing the token being rejected.


     I cannot make this fail with Postman, so it is specific to how Javelin is sending the REST commands.

 

Cause

A change in code in the TDM portal

Environment

TDM Portal: 4.9.1
Javelin 4.9.X

Component: CA Test Data Manager - TDM Web Portal

Resolution

Update the portal to version 4.9.207 (latest patch) or newer.

Please download the latest FDM patch from below link. Install the patch and verify the issue.

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/Test-Data-Manager-TDM-Patches/16649

Attachments