Autoforecast stuck in status "Preparing" with java.lang.NumberFormatException in JWP log
search cancel

Autoforecast stuck in status "Preparing" with java.lang.NumberFormatException in JWP log

book

Article ID: 201493

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Autoforecast hangs after clicking on Recalculate in the Autoforecast screen but the expected message below is never received:
"Autoforecast data calculated from MM/DD/YYYY HH:MM to M/DD/YYYY HH:MM"

The following Exception appears in the JWP log:

20200828/103454.126 - 106    U00003434 Die Serverroutine 'ForecastMessageHandler/JFCST' benötigte '0' Minuten '6' Sekunden zur Durchführung.
20200828/103500.353 - 106              Unhandled Exception in thread MQWorker-1 ID=106
20200828/103500.353 - 106    U00045014 Fehler 'java.lang.NumberFormatException: "For input string: "0 ""' in 'java.lang.NumberFormatException.forInputString():76'.
20200828/103500.354 - 106    U00003620 Routine 'com.automic.kernel.impl.DefaultExceptionHandler' öffnet Zwangstrace wegen Fehler.
20200828/103500.359 - 106    U00003450 Die TRACE-Datei wurde mit den Schaltern '0000000000000000' geöffnet.
20200828/103501.939 - 106    U00003449 Die Ausgabe in die TRACE-Datei wurde beendet.

or:

20200828/103454.126 - 106    U00003434 Server routine 'ForecastMessageHandler/JFCST' required '0' minutes and '6' seconds for processing.
20200828/103500.353 - 106              Unhandled Exception in thread MQWorker-1 ID=106
20200828/103500.353 - 106    U00045014 Exception 'java.lang.NumberFormatException: "For input string: "0 ""' in 'java.lang.NumberFormatException.forInputString():76'.
20200828/103500.354 - 106    U00003620 Routine 'com.automic.kernel.impl.DefaultExceptionHandler' forces trace because of error.
20200828/103500.359 - 106    The TRACE file was opened with the switches '0000000000000000'.
20200828/103501.939 - 106    U00003449 Output to the TRACE file is finished.

 

 

Environment

Release : 12.x and 21.x

Component : AUTOMATION ENGINE

Area: Forecast

Cause

This is due to wrong values for the JPP_MrtTime inside some objects.

The values in JPP_MrtTime is supposed to be a 6-digit string, but when the issue occurs the value "0" is found.

The reason being that in JPP table, the value JPP_MrtTime had 0 instead of 000000, in order to identify the "corrupted" objects, the following query can be launched:

select oh.OH_idnr, oh.OH_Name as WF, jpp.JPP_Object as task, jpp.JPP_MrtTime from oh, jpp where oh.oh_idnr = jpp.JPP_OH_Idnr and jpp.JPP_MrtTime != '000000';

The results of that query will list the workflows that are "corrupted".

Resolution

In order to solve this issue, there are two options:

  1. Using the query indicated in the Cause section above, update the "corrupted" JPP lines with JPP_MrtTime different than 000000 and set it to 000000
  2. Export/import the affected Workflows (JOBP objects) this is because in the XML file of the export, the field MrtTime of the Task has already the correct format (HH:MM).


(Note that using the Transport Case probably won't work, because this copies the content directly from the database).