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DX APM SAAS - How can we stop OI sending informational alarms for APM alerts

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Article ID: 201485

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Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

We have defined some alerts in APM for which we want a notification only when the metric value crosses the threshold. The definition in APM is set to 'When severity increases' however we are getting notifications when the value returns to normal which we do not want - why is this happening and how can we stop it?

 

Cause

This is a known problem and documented 
 
Defect DE466013: APM Alert - Trigger Notifications Alert Choice Ignored

This issue happens after you select a trigger alert notification when creating a new alert.  

DX APM does not apply the trigger correctly when the alert level changes. For example, you create an alert, and select the option to be notified

When Severity Increases

When the alert severity actually changes from Critical to Major to OK

DX APM should not send an alert email notification. However, the notification channel triggers, incorrectly sending an email notification when the alert severity is reduced.

 

Environment

Release : SAAS

Component : Introscope

Resolution

Suggested workaround - may not be suitable to all situations

- In OI create a policy to filter only Major and Critical alerts and apply that to the notification channel associated to the alert. 

 

Please note that in doing this it will apply All Alarms  to the selected notification channel so additionally it will be necessary to filter the policy to match only those Alarms that you wish to use that notification channel