search cancel

XCOM server on one LPAR and BATCH jobs on another LPAR

book

Article ID: 201424

calendar_today

Updated On:

Products

XCOM Data Transport XCOM Data Transport - z/OS XCOM - SUPPORT

Issue/Introduction

We asked if it was possible to have an XCOM server running in LPAR O while all batch jobs that use XCOM run on LPAR B.

As per recommended, VTAM folks configured the cross domain APPLs in our LAB system, but we could not schedule or access LAB1's XCOM from LAB3.

These are the outputs from D NET commands executed on LAB3, that show that XCOM's APPLs running on LAB1 are "viewable":

D NET,ID=XCOMLAB1                                                  
IST097I DISPLAY ACCEPTED                                           
IST075I NAME = XCOMLAB1, TYPE = CDRSC 274                          
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV                        
IST599I REAL NAME = ***NA***                                       
IST1402I SRTIMER =    30  SRCOUNT =    10                          
IST1447I REGISTRATION TYPE = NO                                    
IST977I MDLTAB=***NA*** ASLTAB=***NA***                            
IST1333I ADJLIST = ***NA***                                        
IST861I MODETAB=***NA*** USSTAB=***NA*** LOGTAB=***NA***           
IST934I DLOGMOD=***NA*** USS LANGTAB=***NA***                      
IST597I CAPABILITY-PLU ENABLED  ,SLU ENABLED  ,SESSION LIMIT NONE  
IST231I CDRSC MAJOR NODE = CDXCOM                                  
IST479I CDRM NAME = ***NA***, VERIFY OWNER = NO                    
IST1184I CPNAME = xxxxxx.CDLAB1 - NETSRVR = ***NA***              
IST082I DEVTYPE = CDRSC                                            
IST654I I/O TRACE = OFF, BUFFER TRACE = OFF                        
IST1500I STATE TRACE = OFF                                         
IST228I ENCRYPTION = NONE , TYPE = DES                             
IST1563I CKEYNAME = XCOMLAB1 CKEY = PRIMARY CERTIFY = NO           
IST1552I MAC = NONE MACTYPE = NONE                                 
IST171I ACTIVE SESSIONS = 0000000000, SESSION REQUESTS = 0000000000
IST924I -----------------------------------------------------------
IST075I NAME = xxxxxx.XCOMLAB1, TYPE = DIRECTORY ENTRY            
IST1186I DIRECTORY ENTRY = DYNAMIC LU                              
IST1184I CPNAME = xxxxxx.CDLAB1 - NETSRVR = ***NA***              
IST484I SUBAREA = 23                                               
IST1703I DESIRED LOCATE SIZE = 1K LAST LOCATE SIZE = 16K           
IST1402I SRTIMER =    30  SRCOUNT =    10                          
IST314I END                                                        

D NET,ID=XCOM100                                                   
IST097I DISPLAY ACCEPTED                                           
IST075I NAME = XCOM100, TYPE = CDRSC 367                           
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV                        
IST599I REAL NAME = ***NA***                                       
IST1402I SRTIMER =    30  SRCOUNT =    10                          
IST1447I REGISTRATION TYPE = NO                                    
IST977I MDLTAB=***NA*** ASLTAB=***NA***                            
IST1333I ADJLIST = ***NA***                                        
IST861I MODETAB=***NA*** USSTAB=***NA*** LOGTAB=***NA***           
IST934I DLOGMOD=***NA*** USS LANGTAB=***NA***                      
IST597I CAPABILITY-PLU ENABLED  ,SLU ENABLED  ,SESSION LIMIT NONE  
IST231I CDRSC MAJOR NODE = CDXCOM                                  
IST479I CDRM NAME = ***NA***, VERIFY OWNER = NO                    
IST1184I CPNAME = xxxxxx.CDLAB1 - NETSRVR = ***NA***              
IST082I DEVTYPE = CDRSC                                            
IST654I I/O TRACE = OFF, BUFFER TRACE = OFF                        
IST1500I STATE TRACE = OFF                                         
IST228I ENCRYPTION = NONE , TYPE = DES                             
IST1563I CKEYNAME = XCOM100 CKEY = PRIMARY CERTIFY = NO            
IST1552I MAC = NONE MACTYPE = NONE                                 
IST171I ACTIVE SESSIONS = 0000000000, SESSION REQUESTS = 0000000000
IST924I -----------------------------------------------------------
IST075I NAME = xxxxxx.XCOM100, TYPE = DIRECTORY ENTRY             
IST1186I DIRECTORY ENTRY = DYNAMIC LU                              
IST1184I CPNAME = xxxxxx.CDLAB1 - NETSRVR = ***NA***              
IST484I SUBAREA = 23                                               
IST1703I DESIRED LOCATE SIZE = 1K LAST LOCATE SIZE = 16K           
IST1402I SRTIMER =    30  SRCOUNT =    10                          
IST314I END                                                        

 

For the XCOM running on LAB1, the config member has these values: ACBNAME=XCOMLAB1 and JOBACB=XCOM1. We tried defining the APPLs both static and dynamic, with the same result.

What we also found, was that XCOM always keeps an active session on XCOMLAB1, but for XCOM1** they remain contactable (CONCT). We have also tested that if from LAB3 we perform a LOGON APPLID(XCOMLAB1) the connection is made: "X01280001XCOMM0378I LOGON SUCCESSFUL - TO END, ENTER LOGOFF" appears on the 3270 session, and this appears on the log:

 

XCOMM0719I SESSION ESTABLISHED WITH SLU=TCPC0028, MODE=SNX32704,
CID=FC000005, DEST=**NONE**, SRUSIZE=03840, RRUSIZE=01024       
XCOMM0192E INVALID TPN RECEIVED        - XCOMRAN2               
XCOMM0151I TCPC0028 SESSION ENDED   CID=FC000005                

 

This is expected, but proves the LAB1 XCOMLAB1 APPL is actually found from LAB3.

But if we do the same thing for APPL XCOM100 from LAB3, this time there's no connection and these errors appear on the log:

LAB3:
IST663I IPS SRQ REQUEST TO ISTAPNCP FAILED, SENSE=08570002 277  
IST664I REAL  OLU=xxxxxx.TCPC0029    ALIAS DLU=xxxxxx.XCOM100 
IST889I SID = DA3F4B7D2B7096A0                                  
IST1669I IPADDR..PORT 129.39.167.210..45872                     
IST264I REQUIRED RESOURCE XCOM100 NOT ACTIVE                    
IST891I xxxxxx.CDLAB1 GENERATED FAILURE NOTIFICATION           
IST314I END                                                     

LAB1:
IST663I IPS SRQ REQUEST FROM ISTAPNCP FAILED, SENSE=08570002 107
IST664I REAL  OLU=xxxxxx.TCPC0029    REAL  DLU=xxxxxx.XCOM100 
IST889I SID = DA3F4B7D2B7096A0                                  
IST1669I IPADDR..PORT 129.39.167.210..45872                     
IST264I REQUIRED RESOURCE XCOM100 NOT ACTIVE                    
IST2103I RSCV TOWARDS SLU                                       
IST1460I TGN  CPNAME             TG TYPE      HPR               
IST1461I  21  xxxxxx.CDLAB3     APPN         RTP               
IST314I END                                                     

What we saw is that XCOMLAB1 is ACTIVE in LAB1 since XCOM took it, but XCOM1* are CONCT, so not active. Maybe that's it?.

Are we doing something wrong?, is there any particular configuration that should take place from VTAM point of view?.

 

Environment

Release : 12.0

Component : CA XCOM Data Transport for z/OS

Resolution

The XCOM1xx is the minor ACB and it will stay in that CONCT status because XCOMJOB is the one that will use it.

You need to make sure that the minor ACB's are on the same LPAR as XCOMJOB because the status for them will go from CONCT to ACTIVE status when XCOM opens it. The OPEN won't work across another LPAR.

XCOMLAB1 is the major ACB and that will be ACTIVE and that is what the XCOM server uses.

So, make sure that this is configured in VTAM correctly.