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Change Orders have negative epoch dates defaulted for empty date fields in 17.3

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Article ID: 201415

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Before upgrading to r17.3.0.1, when a change order is created without setting a start date, the field has a null value in the database. 
But after we upgraded our environment to r17.3.0.1 instead of null, a negative epoch date (-2147483648), this behavior was observed in all date fields.

One example query is below:

Before (17.1):

After (17.3.0.1):

Cause

This is due to changes made as part of the 64-bit architecture changes. 

Environment

Release : 17.3

Component : SERVICE DESK MANAGER

Resolution

Please open a case in Support and inform the behavior you are experiencing and request the correction made available through the #DE58049.

Additional Information

 - To apply the fix that will be delivered it is necessary to have the ApllyPTF, if you do not have please follow the instructions for downloading the article below:
Where can I locate the latest APPLYPTF and Cazipxp Utility from the CA Support Online Portal ?

 - If your MSSQL is 2016 or higher you will need to follow this article because the installation attempt by the ApplyPTF GUI interface may fail.
ApplyPTF: Errors seen when trying to install test fixes using ApplyPTF GUI

ApplyPTF attached to this article.

Attachments

1602688695133__APPLYPTF.rar get_app