search cancel

Update jQuery javascript libraries and handlebars

book

Article ID: 201400

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

Is it possible to update  javascript libraries to the lastest version of jQuery and handlebars used by the resource

"<policy_server_host>:8443/iam/siteminder/resources/fedmgr/javascript/jquery.js" and

"<policy_server_host>:8443/ca/api/sso/services/v1/api-doc/lib/handlebars-2.0.0.js" or just updating the CA SSO solution to the lastest version (12.8.04)?

The current versions of each lib are:

• jQuery 3.2.1

• handlebars 2.0.0

 

 

Environment

Release : 12.8.03

Component : SITEMINDER -WEB AGENT FOR APACHE

Resolution

JQuery can be updated outside of Siteminder:

 

1: Out-of-date Version (jQuery)

1.1. https://federationstage.nih.gov/js/jquery-1.11.0.min.js

PROPOSED SOLUTION: 

Update the version of JQuery used by your web servers.