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Continuous ServiceDesk disconnect and reconnect messages in Spectrum tomcat logs.

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Article ID: 201216

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Updated On:

Products

CA Spectrum CA Service Desk Manager

Issue/Introduction

Continuous ServiceDesk disconnect and reconnect errors in Spectrum tomcat  logs. This messages are repeated every one minute. 

Oct 08, 2020 10:45:03.349 - Connection to Service Desk service has been lost. Reconnect timer started. 
Oct 08, 2020 10:45:03.458 - Connection to Service Desk web service has been established.
Oct 08, 2020 10:46:03.460 - Connection to Service Desk service has been lost. Reconnect timer started. 
Oct 08, 2020 10:46:03.522 - Connection to Service Desk web service has been established.

Cause

1. Make sure there is no Network problem or latency between Spectrum OneClick Server and Servicedesk. 
2. Run Wireshark or Tcpdump on OneClick Server. Capture only the packets between OneClick Server and Servicedesk Server. 
You will see TCP connection are not closing proper and packets with RESET Flag from ServiceDesk to OneClick. 
 
3) In the below screenshot. Spectrum expects a ServerStatusReturn value as ZERO. But we see the Servicedesk is sending the value as 1. Because of which Spectrum drops the connection. 
 
 

Environment

Release : 10.x

Component : MITS SPECTRUM INTEGRATION

Resolution

This is known issue in ServiceDesk. This is fixed in 17.2.0.8 and 17.3.0.1.

Worked under defect 

DE54078 :- Spectrum Alarm Submit service desk error message because of ServerStatus wrong. Spectrum and CA SDM  integration Test works, but when SDM ticket creation is attempted via a Spectrum Alarm,  got an error message.  SPC-OCC-10262: Error launching serviceDesk/createTicket?alarmId=5e66f49-51c1-

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-2/Release-Notes/CA-Service-Management-17_2_0_8-Release-Notes/Fixed-Issues-17_2_0_8.html

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/CA-Service-Management-17_3_0_1-Release-Notes/Fixed-Issues-17_3_0_1.html

The ServiceDesk patch can be downloaded from below link. 

https://support.broadcom.com/external/content/release-announcements/CA-Service-Desk-Manager-Solutions--Patches/6396

For more information open a Support Ticket with Servicedesk Product. 

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