Sudo Data Collector IP Domain reassignment fails in Performance Management
search cancel

Sudo Data Collector IP Domain reassignment fails in Performance Management

book

Article ID: 201183

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

In Performance Management IP Domain assignment failed for a Data Collector.

The primary error received states "Data collector could not be assigned to the IP Domain".

Numerous sub-errors may appear below the primary error. One type might be a httpResponseCode: 204 error for the Data Aggregator host name or IP address.

After making the change, the Data Collector dcmd service is not restarted to register the change. It's start time seen in the 'Active' value entry from the "systemctl status dcmd" did not change.

The Data Collector configuration file that should be updated with the new IP Domain is updated and does show the correct new IP Domain. This is seen in the (default path) /opt/IMDataCollector/apache-karaf-2.4.3/etc/com.ca.im.dm.core.collector.cfg file.

The Data Collector install is owned and managed by a sudo root user.

Environment

All supported Performance Management releases

Cause

The sudoers file configuration is not set correctly.

Resolution

To resolve this add the following entry for the sudo user managing the Data Collector. The use of the NOPASSWD call will resolve this and the Data Collector will now restart properly after IP Domain changes.

Cmnd_Alias CA_DATACOLL =  /tmp/install.bin,/sbin/service dcmd *, /opt/IMDataCollector/Uninstall/Uninstall, /opt/IMDataCollector/RemoteEngineer/re.sh, /opt/IMDataCollector/scripts/dcmd
sudouser ALL = NOPASSWD: CA_DATACOLL