CCS 'Standard Detail' PDF reports are empty when generated from a custom standard
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CCS 'Standard Detail' PDF reports are empty when generated from a custom standard

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Article ID: 201128

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

Control Compliance Suite (CCS)

When creating a 'Standard Detail' report on a custom or copied standard, the pdf file that is generated has some basic header information, but the information of the checks is missing or blank.

Environment

Release: CCS 12.6.1

Component: Application Server

Cause

When a standard is copied or created, that information from that standard is not copied over to the Reporting Database.  Since there is no information in the CCS Reporting database, that information is missing from the 'Standard Detail' report.

Resolution

The information from that standard will be synchronized with the Reporting database after one of the following:

  • A 'Reporting Database Synchronization Job' system job completes (by default this happens every night).
  • A Collection-Reporting-Evaluation (CER) job is run using that standard on at least one asset, and in the job has the value 'Synchronize evaluation results with reporting database' enabled.

Note:  Also make sure the option is checked (enabled) to do immediate synchronization to the Reporting database when an Evaluation job occurs:  (Located in Settings -> Application Settings -> Reporting Synchronization) 

Additional Information

This can also happen when a Standard is updated, and the version of the Standard gets updated.
Since the data in the database is associated with a specific version of the Standard.

Run a new CER job or Data Collection followed by Evaluation to get data in the database using the new version of the Standard.
Make sure to verify all the above to ensure the data is being synchronized.