Admin account can't work into gtdatamaker and agile designer
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Admin account can't work into gtdatamaker and agile designer

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Article ID: 201014

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We are using LDAP to login to GT DataMaker and to ARD.
When we do we get an error after the login process.

If I try to log in into ARD next message appear

 

We do not have a system with the name http://tempuri.org

How can we solve this error?

 

Environment

TDM Portal 4.9.x
ARD 3.1

 

Cause

The Client had an issue with the database a few days previous and had to reset the permissions on the gtrep database.
Everything else was working except for the connections to the TODO service.

Resolution

Restart the TODO Windows Service.

Additional Information

Full troubleshooting steps taken:
Below is a recap of what we saw and did.
1) when logging into ARD or GT DataMaker you would get an error about the TDOD service Authentication failure.
2) you could bypass it and continue to work in DataMaker.
3) if we went to the TDOD configurator and did a test on all of the tabs they all worked.
4) when we turned on the debug level in the datamaker we got the following error:
07-10-2020 13:09:07 - Transaction connect : SQLCODE=0, SQLDBCODE= 0, Message="Data Source connection. SQL Text = ""."
07-10-2020 13:09:07 - Title: Service Layer : http://tempuri.org/GT_I/AuthenticateUser
Message: Operation: AuthenticateUser: Authorization failed. Please contact administrator to add you to authorized group(s):
Detail:
07-10-2020 13:10:15 - Message: Return Code = 1
07-10-2020 13:10:15 - Title: Service Layer
Message: Unable to connect the service layer.
Detail:
07-10-2020 13:10:58 - Message: Return Code = 1
07-10-2020 13:11:02 - Exit
5) you have no idea what the URL http://tempuri.org/GT_I/AuthenticateUser is as this is not part of your infrastructure.
6) we checked the domain user <USERNAME> by doing a net user <USERNAME> /domain and it returned the correct information.
7) We then went to services and saw that TDOD was using a local system account to login.
8) I restarted the service to get a clean TODO log
9) when we tried to recreate the issue we no longer saw the problem in DataMaker nor ARD.

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