Agent showing started in smgr, but not showing in Administration perspective
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Agent showing started in smgr, but not showing in Administration perspective

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Article ID: 200985

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

There is an Agent that is not auto starting when services were restarted.  

Agent log shows that the agent is connecting, but then the WP starts to loop the following a number of times:

02 - 20201002/145834.444 - U00003412 Agent 'getaddrinfo("ip-xxx-xxx-xxx-xxx") - Name or service not known' logged on (Client connection='').
02 - 20201002/145834.444 - Unknown error -2
02 - 20201002/145834.444 - |

where "ip-xxx-xxx-xxx-xxx" is the IP of the server the agent is running on 

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

The Agent and/or CP are not able to communicate on the cp= ip/dns name of the CP

Resolution

In looking at the Agent ini file, the cp= is set to localhost and for some reason the CP and the agent are unable to resolve this even though they are on the same server.

Two changes were necessary to resolve this:
1) Go to the agent ini file and change the cp= setting from "localhost" to the full qualified domain name of the server where the WPs and CPs are running (keep the :2217 at the end of the setting as well).
2) For the WPs and CPs, please open the ucsrv.ini file and change the line that shows:

; hostname=

remove the semi-colon to uncomment this and after the equals sign, put in the fully qualified domain name of the server?
3) Restart all WPs and CPs for the system
4) Restart the agent

If this does not work, send the agent logs as well as the WP and CP logs for analysis