Jasper Jarvis connectivity failed
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Jasper Jarvis connectivity failed

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Article ID: 200944

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Updated On:

Products

CA Virtual Privilege Manager CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

Data in jasper reports is not being updated in a timely manner. We can, for instance, create a user on an endpoint and it will not show up in jasper reports until hours later, or unless we restart jasper.

Environment

Release : 14.0

Component : CA ControlMinder

Cause

There was no network traffic between jasper and jarvis when we re-executed dashboards. The problem appeared to be relatedto the following post:

https://community.jaspersoft.com/wiki/how-modify-caching-values

Parameters timeToIdleSeconds and timeToLiveSeconds in C:\Program Files\CA\SC\CA Business Intelligence\apache-tomcat\webapps\jasperserver-pro\WEB-INF\adhoc-ehcache.xml default settings are:

timeToIdleSeconds="1800"
timeToLiveSeconds="5400"

By default data that is used will not be replaced for 1.5 hours, which appears to be too long in this environment.

Resolution



Setting these parameters to 60 and 90 and restarting jasper's tomcat service resolved the problem:

timeToIdleSeconds="60"
timeToLiveSeconds="90"