cloud proxy server unable to connect to SaaS tenent using HTTPS instead of WSS
search cancel

cloud proxy server unable to connect to SaaS tenent using HTTPS instead of WSS

book

Article ID: 200889

calendar_today

Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

We want to configure the cloud proxy to communicate to the cloud endpoint (apmgw.dxi-na1.saas.broadcom.com) using protocol https instead of wss, but when I change the config in cloudproxy to as follows it generate an error.

installled from : apmservices.cloudproxy-20.6.0.49.tz

Entire log output:

2020-10-06 10:33:07.588  INFO 29858 --- [main] com.ca.apm.cloudproxy.CloudProxyMain     : Starting CloudProxyMain on myserver with PID 29858 (/apm/proxy/libs/apmservices.cloudproxy-20.6.0.49.jar started by apmuser in /apm/proxy)

2020-10-06 10:33:07.590  INFO 29858 --- [main] com.ca.apm.cloudproxy.CloudProxyMain     : The following profiles are active: cloudproxy

2020-10-06 10:33:07.977 ERROR 29858 --- [main] com.ca.apm.cloudproxy.CloudProxyServer   : Configuration validation failed. Reason: apm.server.proxyTarget scheme 'https' not supported

 

 

Environment

Release : SAAS

Component : Integration with APM

Cause

Cloud Proxy only supports WSS protocol for communication to Cloud Gateway

Resolution

Reconfigure the Cloud Proxy to use standard wss protocol in the application.yml file

 

apm.server.proxyTarget: wss://apmgw.dxi-na1.saas.broadcom.com:443