Agents and Queues Stop/Start functions sporadically stops working
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Agents and Queues Stop/Start functions sporadically stops working

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Article ID: 200850

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Applications Manager Queues can be activated and deactivated at any time. Just like Queues, an Agent can be Stopped or Started at anytime.

Sporadically these functions fail to respond when trying to activate/deactivate or Stopped/Started.

Environment

Component : APPLICATIONS MANAGER

Cause

In most cases, this is due to a configuration with Applications Manager and a load balance set up in Oracle such Oracle RAC or SCAN RAC

Resolution

Applications Manager does NOT support load balancing or any configuration where Applications Manager is not strictly connecting to only one specific database node.

The reason why we need load balancing to be off is that there are known issues with DBMS pipes. Our processes 'sleep' and 'wake up' on DMBS Pipes. Pipes are instance-specific, so if Applications Manager processes are balanced across multiple instances, then wake-ups issued by one process might not activate the target process. This causes the activation/deactivation of the Queue to stop working until a restart is performed.

In any multinode configuration, it is recommended to disable load balancing. 

UPDATE:

As Applications Manager version 9.6, the use of dbms_pipes has been deprecated for Oracle Advanced Queueing. With this change, activating/deactivating Queues or Agents on both single or multinode database configurations should no longer occur. Release Notes for Applications Manager 9.6 can be found here.