VNA Has added duplicates of SNMP managed devices in Performance Management
search cancel

VNA Has added duplicates of SNMP managed devices in Performance Management

book

Article ID: 200752

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

We are seeing behavior where newly added devices through VNA are coming through with IPs that are not their management IP.

This is causing them to not sync one to one with the existing devices which were already in the system causing duplicates.

Environment

Virtual Network Assurance and Performance Management releases r20.2.3 and earlier

Cause

The item being discovered has the UniqueID set in the data. It matches an existing item that has that UniqueID, but a different IP address set.

This prevents the application code from properly reconciling them as the same device.

Resolution

This is resolved via DE479296 which is available in the r20.2.4 and newer Performance Management releases. It's referenced in the following entry in the Fixed Issues documentation.

  • Symptom: DX NetOps Virtual Network Assurance sets the Unique ID to the PK ID, but this is not unique across deployments (with multiple Orchestrators) so the IP address matching is bypassed.
  • Resolution: The serial number is appended to the instance ID.
  • (20.2.4, DE479296)

There is no workaround to resolve the issue in releases r20.2.3 or earlier. Only an upgrade to r20.2.4 or newer would resolve this.

The new code that comes with an upgrade will prevent future instances of duplicates.

The new code does not resolve existing duplicate devices. They will need manual intervention post upgrade to resolve them. To fix these duplicates we'd complete the following:

  • Manually delete the SDN related VNA item.
    • This will delete any related VNA items like tunnels or virtual interfaces.
    • This should not remove any SNMP related items.
  • Do NOT delete the SNMP related item if it's historical data is of any importance. All collected historical SNMP data will be lost if the SNMP device item is deleted instead of the VNA device item.
  • Disable, then re-Enable the VNA Gateway so that it moves from Up to Down and back Up again.

This will result in the loss of SDN history but retention of SNMP historical data.

Deleting and then re-importing and rebuilding the plugin is an option. Though it's only an option recommended where hundreds and hundreds of devices are present making manual deletion an administrative nightmare. 

In all situations ensure appropriate VNA and PC MySql DB backups are created for use in recovery if needed.

Additional Information

Another way to fix this issue:

Stopped wildfly service (service wildfly stop)

Change the /ca/VNA/plugins/ACI Plugin/config/fabrics/controller.pespective

Changed the expression in - name instaceId
 
From:
  - name: instanceId
    expression: path( 'attributes.dn' ).?split( '/sys' )[0]
    required: true
 
To
  - name: instanceId
    expression: path( 'attributes.serial' )  + path( 'attributes.dn' ).?split( '/sys' )[0]
    required: true
 
Started wildfly service (service wildfly start)