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Connection error while trying to connect remote VSE to the devtest registry.

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Article ID: 200407

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Updated On:

Products

CA Cloud Test Mobile CA Application Test

Issue/Introduction

When a VSE is hosted on a remote server and restarted everyday using Windows scheduler Job it throws error like below:
Exception: 
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| Message:     A VSE Server has already been registered in the specified DevTest Registry



Cause

 

VSE connection is not closed by Registry between start and stop caused the issue.

Environment

Release : 10.3

Component : CA Service Virtualization

Resolution

Support to increase the wait time between VSE Start and Stop and also recommended the below:

Registry Server:
1. Stop Registry Service
2. Go to LISA_HOME\lisatmp_xxxx\amq\rpc
3. Delete the folder "2010"
4. Start Registry Service
 
VSE Server:
1. Stop VSE Service
2. Go to LISA_HOME\lisatmp_xxxx\amq\rpc
3. Delete the folder "2013" (or the folder with port number of VSE service if the default port is not used)
4. Start VSE Service

Additional Information

 

It is an intermittent issue.