IP Address wrong in link for "Email/Schedule Report"
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IP Address wrong in link for "Email/Schedule Report"

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Article ID: 200270

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Updated On:

Products

CA Infrastructure Management DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

In the DX NetOps Performance Management Performance Center (PC) web UI Portal I have created a Dashboard and I would like to email that dashboard. I click "Email/Schedule Report" and provide an email address.

The email I get contains a "time sensitive" link but the link contains an IP address which is not the address of the CAPC server, but rather it is the address of our DNS server and obviously is a dead end.

If I replace that IP address with the address or hostname of the CAPC server I am able to download the report.  Is this address/hostname configurable somewhere?

How to change the host or IP address in Performance Management Report emails that contain links to download the report.

Environment

All supported DX NetOps Performance Management releases

Cause

Incorrect "Web Site Host" value set

Resolution

Make the following changes to correct the issue

  • log on to the CAPC shell
  • cd /opt/CA/PerformanceCenter
  • ./SsoConfig
  • #1 for DX NetOps
  • #3 Performance Center
  • Update the "Web Site Host" to the desired value in the "Remote Value" settings

Additional Information

This is documented on the Update Performance Center Website Settings page in the Performance Management documentation.

For r3.7 documentation it's found on the Update Performance Center Website Settings page, Step 7, option 7.

For r20.2 documentation it's found on the Configure the Basic Security Settings Using the SSO Configuration Tool page, Step 6, option 7.

  • 7. Web Site Host
     
    Specifies the URL host for all access to the 
    CA Performance Center
     website.
    To use a specified hostname in emails instead of the IP address for the 
    CA Performance Center
     host, set the Remote Value to that hostname.