Spectrum 10.4.2 Webapp not working with load balancer
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Spectrum 10.4.2 Webapp not working with load balancer

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Article ID: 200175

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

After upgrading to 10.4.2 (DX NetOps 20.2) the WebApp does not work with the load balancer. There are 2 OneClick servers and both can be accessed via http on port 8080, example

http://<OC_1>:8080/spectrum/admin/index.jsp

and

http://<OC_2>:8080/spectrum/admin/index.jsp  

The load balancer is used via http on the same port 8080

http://<LOAD_BALANCER>:8080/spectrum/admin/index.jsp


So clients can access the WebApp via (http://<LOAD_BALANCER>:8080/spectrum/admin/index.jsp) then click the "OneClick WebApp" link which will take them to (http://<LOAD_BALANCER>:8080/spectrum/webapp).

In this case, they just see a blank page after clicking the OneClick WebApp link.

Environment

Spectrum 10.4.2 and later

Cause

Some ports required for internal communication are blocked by FireWall

Resolution

Using the developer console in the browser when attempting to launch the WebApp revealed that the required port 9443, was being blocked:

 

This port is used when accessing OneClick WebApp, so it needs to be opened on the Firewall.
OneclickWebapp runs on 9443 and the internal JMS communication by WebApp is done on 34455.
So TCP port 9443 needs to be opened on the FireWall.