ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

The SCRT reports generated by CCS are incomplete (no SMF89-2 records)

book

Article ID: 200133

calendar_today

Updated On:

Products

COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS Common Services EASYTRIEVE REPORT GENERATOR FOR COMMON SERVICES INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT LDAP SERVER FOR Z/OS CHORUS SOFTWARE MANAGER PAM CLIENT FOR LINUX ON MAINFRAME

Issue/Introduction

After applying the Common Services for z/OS (CCS) maintenance to generate SCRT reports required by Broadcom, the reports seem incomplete.

The SCRT ISV report was obtained but only the CA OPS/MVS and CA SYSVIEW Performance Management products are observed.

Why are there no entries for other CA Mainframe products that are installed?

Cause

  • Required PTFs not installed on system where SMF data collected
  • Report was run for a time period prior to the required CCS PTFs being installed and implemented
  • SMF89 subtype 2 records not being created due to SMFPRMxx definition
  • SMF89 subtype 2 records not being created due to LMPAM=NO defined in CARIMPRM
  • Definition within Product Enablement Policy (IFAPRDxx) that is including CA products, thus preventing our registration to be driven
  • z/OS running as a z/VM guest

 

Notes:

  • SCRT ISV reports use SMF type 89 subtype 2 records
  • These products generate SMF type 89 subtype 2 records on their own
    • CA SYSVIEW, CA OPS/MVS, and CA MIM
  •  SMF 89 records are cut when an LMP check is done for each product.
    • Scheduled by the individual product
    • Results may vary depending upon the scheduled LMP check
    • Reason for the recommended monthly timeframe for the reports

Environment

Release : 14.1 or 15.0
Component : CA Resource Initialization Manager(CAIRIM)

Resolution

  • If LMPAM=NO is defined in CARIMPRM, update to specify LMPAM=YES and rerun CAS9 proc
  • If running z/OS as a z/VM guest, update RMF options member (ERBRMF00) to include VMGUEST
  • Update statement in IFAPRDxx to exclude CA products (eg. STATUS(NOTDEFINED) )
  • Ensure the following maintenance is applied for the appropriate release of Common Services:

    Create SMF89 subtype 2 records for CA products
        r14.1 - SO05852
        r15.0 - SO06284 - included in r15.0 

    Add product versions to the Common Services generated ISV SCRT Reports
        r14.1 - SO07020
        r15.0 - SO07021

    ISV SCRT reports for Broadcom may be associating product codes with incorrect product names
        r14.1 - SO09411
        r15.0 - SO10688

    Provide new ISV SCRT Report JCL (these are the recommended minimum PTF levels)
        r14.1 - SO13697
        r15.0 - SO13696

     Correct product names on SCRT Report & Create SMF89-2 records for additional products
        r14.1 - SO15571
        r15.0 - SO15572

              Add 'Report_Time=UTC_Time' To SCRT Report
               r14.1 - SO15860
               r15.0 - SO15859     

             Remove support from LMPAM=NO on CAS9 startup
               r15.0 - LU00614

             Remove default feature data from SMF89 record
               r15.0 - LU02177

Additional Information

     Review the Common Services r14.1 or r15.0 documentation regarding in section entitled "Generate Sub-Capacity Reports for CA Technologies Products"  
     
     Keep in mind that CCS r14.1 is End of Service since December 31, 2020, see  General Availability Announcement for CA Common Service for z/OS Version 15.0